This project has moved and is read-only. For the latest updates, please go here.

Can't parse the sample 834 Transaction or a standard 997

Sep 4, 2013 at 9:35 PM
So I download the latest binaries and source.
I copied the sample 834 text directly from the "Parsing an 834 Transaction" help screen.
I then ran sample C# code.
But I get error "0 is not a valid subelement separator in position 105 of the file"
When I run the file through the source it breaks at line 40 in OopFactory.X12.Parsing.X12DelimiterSet
The problem is that isaSegmentAndTerminator[105] is invalid.
Basically it combined the ISA which is only 87 characters and the GS together and then read the 105 position which is the "0" from GS02 901234572000

I have tried changesets 26069 - 28968 and they are all broken.
Sep 11, 2013 at 4:42 PM
Edited Sep 11, 2013 at 4:43 PM
I'm sure I am missing something simple here. I can't parse the sample 834 from this site.
I also can't seem to parse any of the EDI files I have such as a simple 997.
They all fail with error "0 is not a valid subelement separator in position 105 of the file".
I know these files are in good format and our BizTalk server is parsing these same files just fine.
What am I doing wrong?

here is the simple 997
ISA*00* *00* *01*9012345720000 *01*9088877320000 *020816*1144*U*00401*000000031*1*T*:~
Sep 11, 2013 at 6:52 PM
The first 106 characters are fixed width. If you copied and pasted this from another location, sometimes some of the password fields get shrunk as it seems to be case from your sample. You may need to lookup up the spec for ISA to see where you need to put some spaces back in, or look at some of the test files here and see if your ISA segment lines up with the one in the example.
Sep 11, 2013 at 10:19 PM
You were right. The spacing was incorrect on the ISA.
After fixing the ISA to the standard X12 00401 spacing the file parsed fine.
Thanks for the help.